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การสรางและดูแลเว็บดวย  Macromedia 
Dreamweaver  MX  

• HTML ภาษาพื้นฐาน 

HTML ยอมาจากคําวา Hypertext Markup Language เปนภาษาหลักที่ใชในการแสดงผลบนเว็บ

บราวเซอรในอินเทอรเน็ต ภาษา HTML แบงออกเปน 2 สวน คือ สวนที่เปนขอความทัว่ๆ ไป และสวน

ที่เปนคําสั่งทีใ่ชในการกําหนดรูปแบบของขอความที่แสดง  ซึ่งเราเรียกวา แท็ก (Tag) โดยคําสั่งของ 

HTML จะอยูในเครื่องหมาย < และ >  

<คําสั่ง>  ขอความ  </คําสั่ง> 

<TITLE> MY HOMEPAGE <TITLE> 

 

• โครงสราง HTML พื้นฐาน  

โครงสรางของภาษา HTML แบงออกไดเปน 4 สวนหลัก ดังนี้ 

<HTML>  

  <HEAD> 

   <TITLE> หัวขอเว็บเพจ <TITLE> 

  </HEAD> 

  <BODY> 

   สวนที่เปนเนื้อหา 

  </BODY> 

 </HTML> 

<HTML>… </HTML> เปนคําสั่งแรกที่ตองมีในภาษา HTML ซึ่งบงบอกวานี่คือภาษา HTML โดย

จะอยูที่จดุเริ่มตนของเอกสารและทายเอกสารในแตละแฟม 

<HEAD> … </HEAD> เปนสวนกําหนดรายละเอียดหัวขอเรื่อง ภายในจะมีคาํสั่งยอยอีกหนึ่งคําสัง่  

คือ <TITLE> … </TITLE> โดยใชชื่อหวัเรื่องของเว็บเพจ ซึ่งจะไปปรากฏอยูบน Title bar ของ

บราวเซอร 

<BODY> … </BODY> สวนนี้เปนสวนของเนื้อหาเว็บเพจของเรา  ไมวาจะเปนขอความ  รูปภาพ  

ตารางเสียง  และการเชื่อมตอไปยงัยังเอกสารอื่นๆ ที่จะแสดงผลที่เว็บบราวเซอร 
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• ความสามารถของ Macromedia Dreamweaver 

เปนโปรแกรมทีใ่ชงานไดงาย คลายกับโปรแกรม FrontPage, HomeSite, HotDog …  ผูใชสามารถ

ออกแบบองคประกอบตางๆ (เรียกวา Object)  ของหนาเว็บเพจไดเอง เพียงแคลากสวนตางๆ เขามา

ประกอบกัน โดยไมจาํเปนตองมีความรูในเรื่องของภาษา HTML (แตหากผูใชมีความรูเก่ียวกับภาษา 

HTML ก็จะเปนประโยชนในเขาใจหลักการทํางาน  การสราง รวมถึงการแกไขไดอยางละเอยีด)  

1. สนับสนุนการทาํงานแบบ WYSIWYG (What You See Is What You Get) คือ เราสรางอะไร 

บนหนาจอ Dreamweaver  ก็จะปรากฏผลแบบเดียวกันที่เวบ็เพจ ทําใหงายตอการใชงาน 

2. มีเครื่องมือชวยในการสรางรูปแบบหนาจอ และมีความยดืหยุนในการใชงานสูง 

3. สนับสนุนภาษาสคริปตตางๆ ทัง้ฝงไคลเอ็นต  และเซริฟเวอร เชน Java, ASP, PHP, CGI, 

VBscript 

4. มีเครื่องมือในการอัพโหลด (Upload) หนาเว็บเพจไปที่เครื่องเพ่ือทําการเผยแพร 

5. รองรับมัลติมีเดยี เชน เสียง กราฟก 

6. มีความสามารถทําการติดตอกับฐานขอมูล เพ่ือความสะดวกในการเขียนแอพพลิเคชั่นบน

เว็บไซต  

• เริ่มตนใชงาน Macromedia Dreamweaver 

 หลังจากที่ตดิตัง้โปรแกรม Dreamweaver MX เรียบรอยแลว สามารถเรยีกใชงานไดดังนี ้

1. คลิกที่ปุม Start 

2. All Program > Macromedia 

3. เลือก Macromedia Dreamweaver MX จะปรากฏหนาแรกใหเราเลือกหนาตางการทํางาน 

โดยจะมี 2 รูปแบบ คือ หนาตางการทํางานของโปรแกรม Dreamweaver MX  หรือจะใช

หนาตางการทาํงานแบบ Dreamweaver 4 
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• แนะนําการใชเครื่องมือใน Macromedia Dreamweaver MX  
 

 

• แถบคาํส่ัง (Menu bar)  

เปนแถบทีใ่ชเก็บคําสั่งทั้งหมดของโปรแกรม 

 

• แถบเครื่องมือ (Tool bar)  

เปนแถบทีร่วบรวมปุมคําสั่งที่ใชงายบอย 

 

• แถบสถานะ (Status bar) 

 

• สวนของ Properties (Properties Inspector) 

แตละ Object ที่เรานํามาใชสรางหนาเว็บเพจจะมคีุณสมบตัติางๆ ที่เราสามารถปรับแตงได 
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• สวน Panel Group  

เปนสวนที่เพ่ิมข้ึนมาเพื่อใหสามารถใชในการตดิตอกับฐานขอมูลฝงเซิรฟเวอร เพ่ือใหงายในการสราง 

Application บน Internet 

 

• รายละเอียดของแทบ็ Insert (Insert Bar) 

เปนกลุมเครื่องมือองคประกอบตางๆ (Object) ที่จะนํามาสรางหนาเว็บเพจ มี 12 กลุม ดังนี้ 

แท็บ Common  

เปนสวนทีร่วบรวมกลุมเครื่องมอืที่ใชสรางองคประกอบตางๆ ของเว็บ เชนการแทรกภาพ การแทรก

ตาราง การกําหนดลิงค เปนตน 

  กําหนดลิงค                 กําหนดอีเมลลิงค      แทรกตาราง 

  แทรกรูปภาพ        แทรกFlash        แทรกวันที ่

  กําหนดลิงคในเว็บเพจเดียวกัน 

แท็บ Layout 

เปนสวนรวมเครื่องมือทีช่วยในการจัดองคประกอบของหนาเว็บเพจ 
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แท็บ Text  

เปนที่รวบรวมคาํสั่งเก่ียวกับการใชงานตัวอักษร 

แท็บ Table  

รวบรวมคําสั่งในการสรางตารางใหกับเว็บเพจ 

 

แท็บ Frames  

รวบรวมคําสั่งทีใ่ชในการแบงหนาเว็บเพจใหออกเปนสวนยอย 

 

แท็บ Forms 

 แทรกเครื่องทีใ่ชในการสรางแบบสอบถาม และตัวเลือกตางๆ 

 

แท็บ Templates 

ใชในการกําหนดรูปแบบใหกับเว็บเพจ 

 

 

แท็บ Characters  

เปนกลุมเครื่องมือที่ใชแทรกตวัอักษร และสญัลักษณพิเศษ 

 

  การแทรก Line Break    การแทรกที่วาง 

แท็บ Media  

ใชสําหรับแทรกไฟลวิดีโอ, ภาพเคลื่อนไหว, Flash, Java applet, ActiveX หรือ Plugin ในหนาเว็บ 



การสรางและดูแลเว็บดวย Macromedia Dreamweaver MX สุวิมล  คงศักด์ิตระกูล 

เอกสารประกอบการอบรมโครงการอบรมสําหรับผูดูแลเว็บหนวยงานของมหาวิทยาลัย   6

  การแทรกไฟล Flash     การสรางปุมแบบ Flash    การสรางตัวอักษรแบบ Flash 

แท็บ Head 

เปนการแทรกคาํสั่งเสริมในหนาเว็บ เชน คียเวริด เพ่ือให Search Engine สามารถคนหาเว็บเราได 

 

แท็บ Script  

ใชในการแทรกภาษาสคริปตในเว็บ 

แท็บ Application 

เปนแท็บทีร่วบรวมคาํสั่งที่ใชสรางแอพพลิเคชั่นตดิตอกับฐานขอมูลผานเวบ็เซิรฟเวอร 

 

 

• หนาตางเว็บเพจ (Document Window) 

สําหรับหนาตางการทํางาน  Macromedia Dreamweaver MX สามารถเลอืกได 3 รูปแบบ 

 Show Code View เปนหนาตางที่แสดงเฉพาะ HTML ของเว็บเพจที่เรากําลงัทํางานอยู 
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 Show Code and Design Views เปนหนาตางที่แสดงทั้ง HTMLและหนาเวบ็เพจที่ออกแบบ 

 

 Show Design View  แสดงแตหนาเว็บเพจปกติไมแสดง HTML 

 

• ทําให Dreamweaver ใชภาษาไทยได 

ตองติดตั้งฟอนตภาษาไทย (thai addon) หลังติดตั้งเรยีบรอยแลวเมื่อเขามาที่โปรแกรม 

Dreamweaver ใหเลือกคําสั่ง Edit > Preferences และเลือก Fonts เพ่ือกําหนดภาษาและชุด

ตัวอักษร โดยในชอง Font Settings ใหเลือก THAI Windows-874 
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• เริ่มตนสรางเว็บไซต  
1. ไปที่เมนู Site >New Site 

2. เลือกแท็บ Advanced   

3. Site Name กําหนดชื่อใหกับเว็บไซต  

4. Local Root Folder คลิก  เลือกโฟลเดอรทีต่องการเก็บ เว็บไซต  
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การเริ่มตนสราง Site งาน ครั้งแรกโปรแกรมถามวา ตองการสรางไฟล cache สําหรับเว็บไซตหรือไม 

ไฟล cache ใชในการปรับไฟลตาง ๆ ในเว็บไซตใหเชื่อมโยงถูกตอง แมจะยายไฟลขามโฟลเดอร

ยอยก็ตาม หากไมตองการใหมีขอความนี้เตือนทุกครั้ง  ให Don’t ask again  

5. Dreamweaver จะแสดงโฟลเดอรที่เก็บไซตใหมในหนาตางแท็บ Site  

 

• การสรางโฟลเดอรใหมในเว็บไซต   

เลือก Files > New Folder จากเมนูของแท็บ Site หรือคลิกขวาที่โฟลเดอรที่เราเก็บเว็บไซตเลือก 

New Folder 
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• การสรางเว็บเพจใหมในโฟลเดอร  

เลือก File>New File จากแทบ็ Site หรือ คลิกขวาที่โฟลเดอรที่ตองการสรางหนาเว็บเพจใหม  เลือก 

New File 

 

 

 

 

• การกําหนดคุณสมบัติของหนาเว็บเพจ (Page Properties) 

กอนเริ่มตนสรางเว็บควรเริ่มกําหนดคุณสมบตัหิลักของหนาเว็บกอน  โดยการเลือกคําสั่ง Modify > 

Page Properties จากเมนูบาร หรือคลิกขวา เลือกคําสั่ง Page Properties  จะพบหนาตาง Page 

Properties  

รายละเอียดในหนาตาง Properties 
1. Title กําหนดหวัเรื่องของหนาเว็บ 

2. Background Image กําหนดภาพทีใ่ชเปนฉากหลังของหนาเว็บ 

3. Background กําหนดสีทีต่องการใหเปนพ้ืนหลังของหนาเว็บ 

4. Text กําหนดสตีัวอักษรปกต ิ

5. Links กําหนดสใีหกับตัวอักษรที่ทาํการ Links  

6. Visited Links กําหนดสีใหกับตัวอักษรที่เคยคลิก Links  

7. Links Links กําหนดสีใหกับตวัอักษรขณะคลกิ Links  

8. Active Links กําหนดสีใหกับ Links แบบตาง ๆ  

9. Left Margin กําหนดระยะขอบซายของหนาเวบ็ (ใชกับบราวเซอร Explorer) 

10. Top Margin กําหนดระยะขอบบนของหนาเว็บ (ใชกับบราวเซอร Explorer) 

11. Margin Width กําหนดระยะขอบซายของหนาเว็บ (ใชกับบราวเซอร Netscape) 

12. Margin Height กําหนดระยะขอบบนของหนาเว็บ (ใชกับบราวเซอร Netscape) 

13. Document Encoding กําหนดชดุตัวอักษร (ใหใช Thai Windows-874) 



การสรางและดูแลเว็บดวย Macromedia Dreamweaver MX สุวิมล  คงศักด์ิตระกูล 

เอกสารประกอบการอบรมโครงการอบรมสําหรับผูดูแลเว็บหนวยงานของมหาวิทยาลัย   11

14. Tracing Image และ Image Transparency ใชกําหนดภาพที่ใชอางอิงหรือใชเปนเทม

เพลต 

 

• ขอความ (Text) 

สามารถพิมพขอความไดเหมือนการพิมพเอกสารใน MS Word และกําหนดคุณสมบตัติางๆ เชน 

รูปแบบขอความ, การจดัตาํแหนงขอความ (Alignment) 

 

• รูปภาพ (Image) 
1. เลือกรูปที่ตองการโดยกดปุม  (Image) หรือไปที่เมนู Insert> Image 

2. เลือกไฟลรูปภาพจากเครื่อง PC  

3. พิมพคําอธิบาย ในหัวขอ Alt ( ภาพที่นํามาแสดงบนเว็บเพจ บางครั้งไมสามารถ Load 

ภาพขึ้นมาแสดงได) 

 

• การเชื่อมโยง (Link)  
การเช่ือมโยงภายในเว็บเพจเดียวกัน 

1. กําหนดจดุ Anchor หรือจดุ Link ที่จะกระโดดไปในหนาเว็บเพจนั้น 

2. คลิกเมาสที่แถบ Common หรือเลือกจากเมนู Insert > Named Anchor 
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3. ตั้งชื่อจดุ Anchor แลวคลิกที่ปุม OK 

 

4. คลิกคลุมขอความทีต่องการกําหนดใหเชื่อมโยง กําหนดการเชื่อมโยง โดยการพิมพ # 

ตามดวยชื่อจุด Anchor 

 

กําหนดลกัษณะของเพจใหมที่เช่ือมโยง 

รูปแบบการแสดงผลบนเฟรมจากชอง Target ในแถบ Properties หรือเลอืกไดจากเมนู Modify> Link 

Target 

1. _blank ใหเปดเพจที่เชื่อมโยงในหนาตางใหมอีกหนาตาง 

2. _parent ใหเปดเพจที่เชื่อมโยง แสดงเพจหนาเดิม 

3. _self ใหเปดเพจที่เชื่อมโยง แสดงในเฟรมเดยีวกันกับที่มีขอความอยู 

4. _top ใหเปดเพจที่เชื่อมโยงขยายเตม็หนาจอ 

 

การเช่ือมโยงภายในเว็บไซตเดียวกัน 

1. คลิกเลือกขอความ หรือ รูปภาพ ที่จะกําหนดใหเชื่อมโยง  

2. กําหนดจดุเชื่อมโยงโดยคลิกที่ปุม จาก Properties ที่ชอง Link  

3. เลือกไฟลทีต่องการเชื่อมโยง 

 
การเช่ือมโยงเว็บไซตอื่น 

1. คลิกเลือกขอความ หรือ รูปภาพที่จะกําหนดใหเชื่อมโยง  

2. พิมพชื่อ เว็บไซต โดยใหพิมพ http:// นําหนาชื่อเว็บเพจทีเ่ราตองการเชื่อมโยง ทีช่อง Link 

จาก Properties เชน http://www.swu.ac.th  

 
การเช่ือมโยงดวยอีเมล 

1. เลือกขอความ หรืออีเมล ทีต่องการกําหนดใหเชื่อมโยงไปยังอีเมล  
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2. พิมพอีเมลแอดเดรสทีช่อง Link จาก Properties โดยพิมพคาํวา mailto: ตามดวยชื่ออีเมลที่

ตองการใหสง เชน mailto:suwimon@swu.ac.th 

 
การเช่ือมโยงดวย Map Link 

เปนการทําภาพในเว็บเพจ ที่ประกอบดวยพ้ืนที่ยอยทีถู่กกําหนดใหเชื่อมโยงกับขอมูล โดยสามารถคลิก

ที่สวนตาง ๆ ของภาพเพื่อเชื่อมโยงไปยังขอมูลทีแ่ตกตางกันได 

1. คลิกภาพที่จะสราง Map Link  

2. เลือกบริเวณทีต่องการ Link โดยใชออบเจ็กต จาก Properties 

3. กําหนดพื้นที่ของรูปภาพที่จะเชื่อมโยง โดยการคลิกเมาสคาง แลวลากใหเปนกรอบ 

4. เลือกไฟลทีต่องการเชื่อมโยง โดยคลิก  

• ตาราง (Table) 
 

1. คลิกเมาส ตําแหนงทีต่องการวางตาราง 

2. คลิกที่ปุม  เครื่องมือสรางตาราง Insert Table ในแถบ Object ปรากฏ กรอบทํางาน ดังนี้ 

  

กําหนดรายละเอียดของตาราง คอื  

• Rows จํานวนแถวของตาราง  

• Columns จํานวนคอลัมนของตาราง  

• Width ความกวางของตาราง กําหนดหนวยไดทั้งระบบ % และ Pixel  

• Border ความหนาของเสนขอบรอบตาราง  

• Cell Padding ระยะหางจากขอบขางในของเซลลเขามาในเซลล มีหนวยเปน pixel 

• Cell Spacing ความหนาของเสนคั่นระหวางเซลล  

การลบตาราง 

1. คลิกเลือกตารางทั้งตาราง 

2. กดปุม Delete  

การลบแถว, ลบคอลัมน 

1. คลิกเลือกแถวหรือคอลมันทีต่องการลบ 

2. กดปุมขวาของเมาส ปรากฏเมนูลัด 

3. เลือกคําสั่ง Delete Row หรือ Delete Column  
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การเพิ่มแถว 

1. นําเมาสไปคลิกในเซลลสุดทายของตาราง  

2. กดปุม Tab จะไดแถวใหมตอจากแถวสดุทายของตารางโดยอัตโนมตั ิ 

การแทรกแถว/คอลัมน 

1. คลิกเลือกแถวหรือคอลมันทีต่องการแทรก  

2. กดปุมขวาของเมาส ปรากฏเมนูลัด  

3. เลือกคําสั่ง Insert, Row หรือ Insert Column หรือ Insert Rows or Columns (กรณี

ตองการแทรกมากกวา 1)  

 

• การสรางเฟรมเซตในเว็บเพจ 
 
เฟรม คือ ลักษณะของการแบงพ้ืนที่หนาตางหลัก ของบราวเซอรออกเปนสวนยอย ๆ เพ่ือใชสําหรับ

แสดงเว็บเพจใหแตละสวนแยกจากกันอยางอิสระ  

วิธีการแบงเฟรม ไปที่ แถบ Frames คลิกเลือกรูปแบบเฟรมตามที่ไดออกแบบ 

 

กําหนดรายละเอียดหนาตาง Properties  

 

• Borders กําหนดใหแสดง (Yes) / ไมแสดง (No) ขอบลอมเฟรม (Default คือ Yes) 

• Border Width กําหนดความหนาของเฟรม ถาไมตองการแสดงขอบเฟรม กําหนดคานี้เปน 0 

• Border Color กําหนดสีของขอบเฟรม 

• Column (or Row) and Units กําหนดขนาดของคอลัมน หรือความสูงของเฟรม โดยใหเราระบุ

หนวยที่ใชในชอง Units  

• Pixels หนวย pixel แมนยําทีส่ดุ ในการกําหนดขนาด 

• Percent หนวยเปอรเซ็นตกับเฟรมอ่ืนในหนาตาง 

• Relative หนวยเปอรเซ็นตกับขนาดหนาตางบราวเซอร 
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รายละเอียดแถบ Properties ของหนาเวบ็ในเฟรมยอย 

แถบ ของ Panel Group ดานขวามือของโปรแกรมจะมี เครื่องมือ Advanced Layout ? คลิกเลือกแถบเฟรม 

? คลิกสวนใดสวนหนึ่งของเฟรม  

 

ปรากฏรายละเอียด หนาตาง Properties ของหนาเว็บในเฟรมยอย 

  

Frame Name ตั้งชื่อที่ใชเรียกเฟรมยอย ซึ่งตองอางถึงชื่อเฟรม เม่ือมีการเชื่อมโยงกับ

เฟรมใหใชตัวอักขระเล็กในการตั้งชื่อ 

Src ใหกําหนดชื่อและตําแหนงเก็บไฟลเว็บเพจทีจ่ะถูกนํามาใชในเฟรม 

Borders กําหนดใหแสดง (Yes) / ไมแสดง (No) ขอบลอมเฟรมยอย  

(Default คือ Yes) 

Scroll กําหนดใหแสดง (Yes) / ไมแสดง (No) แถบเลื่อน (Scroll bar) ในเฟรม

ยอยAutoใหแสดงแถบเลื่อนเฉพาะ เม่ือมีขอมูลเกินกวาที่จะแสดงไดบน

หนาจอ (Default คือ Auto) 

No Resize สั่งใหแสดงขอบเฟรมยอย หากไมตองการใหมีการใชเมาส  ปรับขนาดเฟรม

ใหเช็คถูกหนาขอความนี ้

Border Color กําหนดสีขอบเฟรม 

Margin Width 

Margin Height 

กําหนดระยะหางระหวางหนาเวบ็ในเฟรมยอยกับขอบเฟรม 

โดย Margin Width จะวัดจากดานซายของเฟรม  

Margin Height จะวดัจากดานบนของเฟรม 

การแทรกเว็บเพจลงในเฟรม 

1. เปดหนาตางเฟรมโดยเลือกคําสั่ง Window -->Others --> Frames หรือ กด Shift + F2 

2. Click เลือกสวนของเฟรมทีต่องการจะแทรกเว็บเพจ 

3. Click ที่  เพ่ือเลือกไฟลเว็บเพจที่ตองการแทรก 

4. เลือกไฟลทีต่องการแทรก ปรากฏหนาเว็บเพจในเฟรมทีถู่กเลือกไว 
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การบันทึกเฟรมยอย 

1.  เลือกคําสั่ง File>Save All หรอืกดคีย <Ctrl+Shift+S> คือการบันทึกทุกไฟลที่ประกอบเปนหนา

เว็บเฟรม 

2. โปรแกรมจะถามใหบันทึกหนาตอไป ซึ่งจะปรากฏเสนประ รอบ ๆ เฟรมยอย โดยจะบันทึกจากดาน 

ขวาลาง? ซายลาง ? ขวาบน ? ซายบน จนครบทุกเฟรมยอม (ควรตองชื่อใหเหมาะกับตําแหนง

เฟรม) 

หากมีการแกไขหรือเปลี่ยนแปลงทุกครั้งตอง ใชคําสั่งบันทกึ File > Save All Frames 

การเช่ือมโยงหนาเวบ็ในเฟรม 

1. ลากเมาสเลือกขอความทีต่องกําหนดเปน Link 

2. Click mouse  ปุม เพ่ือเลือกไฟลที่จะเชื่อมโยงดวยในแถบ Properties  

3. เลือกไฟลทีต่องการเชื่อมโยงดวยแลว Click ปุม selete 

4. กําหนดรูปแบบการแสดงผลบนเฟรมจากชอง Target ในแถบ Properties ตัวอยางเราเลือก Main 

Frame คือ เฟรมที่อยูดานขาวมือ 

• _blank เปดเพจใหมข้ึนมา 

• _parent แสดงเพจหนาเดิม โดยจะลบเฟรมออก 

• _self แสดงในเฟรมเดียวกันกับที่มีขอความอยู 

• _top ขยายเต็มหนาจอ 

รูปแบบที่เพิ่มมาจากการเชื่อมโยงปกติ คือ 
• mainFrame แสดงเพจใหมในหนา mainframe 

• topFrame แสดงเพจใหมในหนา topFrame 

• leftFrame แสดงเพจใหมในหนา leftFrame 

5. เซฟแลวตรวจสอบผานบราวเซอร เม่ือ Click ที ่Link หนาเว็บเพจที่สามารถเชื่อมโยงได จะถูก

แสดงในสวนเฟรมที่กําหนดไว 

• การใช Cascading Style Sheet 

เปดหนาตาง CSS Styles โดยเลือก Window > CSS Styles 
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คลิกปุม  หรือเลือกคําสั่ง Text > CSS > Edit Style Sheet คลิกปุม New 

 

จะมีรูปแบบใหเลือก 3 รูปแบบ ดังนี้ 

• Make Custom Style เปนการสรางแบบกําหนดชื่อใหม(เรยีกวา Class) 

• Redefine HTML Tag เปนการระบุคําสั่ง HTML ที่จะเปลี่ยนรูปแบบใหเปนสไตลใหม 

• Use Css Selector เปนการกําหนดสไตลให Link ในแตละแบบ 

Define In คือการกําหนดสไตลตามรูปแบบตอไปนี้ 

• New Style Sheet File กําหนดใหสรางสไตลข้ึนมาใหม 

• This Document Only กําหนดใหใชไฟลเอกสารนี้เทานั้น 

คลิกปุม OK 

 

กําหนดรูปแบบที่ตองการใหกับสไตลชที 

• การนําสไตลชีทมาใชงาน 

คลิกปุม  เลือกไฟลสไตลชีทที่เก็บไว แลวคลิกปุม OK 
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โปรแกรมจะทําการสรางโคดให ดังนี้ <link href="/style_sheet/testcss.css" rel="stylesheet" 

type="text/css"> หมายถึงการที่เราเรียกใชไฟลสไตลชีทที่สรางข้ึน 

• การตรวจสอบ Link ในเว็บไซต 

ในระหวางการสรางเว็บไซต อาจมีการกําหนด Link ใหเชือ่มโยงไปยังไฟลตางๆ แตบางครั้งเราอาจ

ไมไดสรางไฟลน้ันข้ึนมา ทําใหเว็บของเราเกิดปญหา Link เสียหรือ Broken Link เราสามารถตรวจสอบ

ปญหานี้ไดโดย 

2. เลือกโฟลเดอรที่ตองการตรวจสอบ Broken Link 

3. เลือก File > Check Links 

 

4. Dreamweaver จะตรวจสอบทกุ Link ในโฟลเดอรและไฟลตาง และสรุปใหเราทราบ โดยแบง

แสดงเปน 3 กลุม ดังนี ้

• Show Broken Link  แสดง Link แบบ Relative ที่เสยี 

• Show External Links แสดง Link  แบบ Absolute ที่เชื่อมโยงไปนอกเว็บไซต 

• Show Orphaned Files แสดงไฟลที่ไมไดเชือ่มโยงกับที่ใดเลย 
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• การกําหนดขอมูลเก่ียวกับเครื่องเซิรฟเวอร 

กอนที่เราจะทําการอัพโหลดขอมูลไปยังเครื่องเว็บเซิรฟเวอรไดน้ัน เราจําเปนตองทราบ ชือ่เครื่องเว็บ

เซิรฟเวอร, Account Name และ Password กอนจึงจะสามารถนําขอมูลข้ึนไปเก็บยังเครื่องเว็บ

เซิรฟเวอรได 

1. เลือก Site > Edit Sites 

2. เลือกเว็บไซต กดปุม Edit 

3. เลือก Remote Info 

4. เลือก FTP 

• FTP HOST พิมพชื่อเครื่องเซิรฟเวอร  >> www.swu.ac.th 

• Host Directory กําหนด directory ของเครื่อง (สวนใหญเราไมตองระบ)ุ 

• Login พิมพชื่อ Account >> www 

• Password พิมพรหสัผาน 

• Check เลือก Use Passive FTP สําหรับการเชื่อมตอกังเครื่องเว็บเซิรฟเวอรที่มีการติดตั้ง

ระบบ Firewall  
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• การอัพโหลดไฟลจากเครื่องเราสูเครื่องเซิรฟเวอร 
1. เลือกไฟลและโฟลเดอรทีต่องการอัพโหลด 

2. คลิกปุม Put Files   เพ่ือนําไฟลเขาเครื่องเซิรฟเวอร หรือ คลกิปุม Get Files  เพ่ือนําไฟล

จากเครื่องเซิรฟเวอรมายังเครือ่ง PC ที่เราทํางาน 

 

 


